WeCenter支持MySQLi与PDO_MYSQL两种数据库模块

服务外包公司     综合布线     2016-4-1    6566    

使用 WeCenter 安装程序, WeCenter 是中国首个基于 PHP + MYSQL 开发的开源化社交问答社区;安装时报错:WeCenter 支持 MySQLi 与 PDO_MYSQL 两种数据库模块, 您的服务器两种都不支持 如下图

002.jpg

用阿里云ecs服务器,怎么才能支持 MySQLi 与 PDO_pdo.dll ?解决方法!

安装pdo_mysql 问题

    
wget http://pecl.php.net/get/PDO_MYSQL-1.0.2.tgz
     tar zxvf PDO_MYSQL-1.0.2.tgz
     cd PDO_MYSQL-1.0.2
     /www/wdlinux/php/bin/phpize
     ./configure --with-php-config=/www/wdlinux/php/bin/php-config --with-pdo-mysql=/www/wdlinux/mysql  
     make
    make install
成功安装了出现代码
  1. Installing shared extensions:     /www/wdlinux/apache_php-5.2.17/lib/php/extensions/no-debug-non-zts-20060613/

也重启相关服务:
  1. service httpd restart
  2. service nginxd restart
 
php.ini 添加
  1. extension_dir=/www/wdlinux/apache_php-5.2.17/lib/php/extensions/no-debug-non-zts-20060613/
    extension=pdo_mysql.so
去掉了这两个的分号
extension=php_pdo.dll
extension=php_pdo_mysql.dll