网际电脑公司-为企业办公运维解决方案服务

三次修联想B460,4天排除10个电路故障

服务外包公司  硬件维修  2014-11-3  8245  0评论
扫码关注

前几天民治电脑店接了一台B460,来的时候是同事接的,说是上家搞过了,开关小板都没有装上,同事接手,限流通电,果然是大短,心想应该就是CPU铁壳的问题,拆机换了铁壳是不大短了,但是一通电的时候就跑0.54,结果同事就刷了BIOS,结果一样,同事还是老老实实量电压吧,结果一量才发现3、5V都没有,其它也没有供电出来,那怎么会是跑0.54呢,结果同事又摸了一下3、5V芯片,当时同事就被爽了一下,大家知道的,那不是跑0.54,那是短路短的,换了芯片,待机还是很高,有0.2几,又摸到EC很烫,拆掉,待机正常了,换掉,通电可以跑到0.23,这次是跑到0.23的,不是短路,3、5V已经正常输出,同事又一量CPU没电压,心想回想以前常修的故障了,把CPU电压修出来就基本上可以了,然后同事换了一CPU芯片,结果一样,又到处量一圈也没发现什么异常,没什么思路了,同事也不想搞了
          第三天,我接手,我量了CPU芯片38P,开启信号为0.6V,往前追为ALL_PWRGD信号,这里我犯了一个错误,因为在图纸上一搜这个信号,直接就弹到3、5V芯片的图纸了,我一量51125的23P也为0.6V,想当然的认为是芯片坏了拉低了开启信号,马上换了一个,结果还是一样,然后我才反应过来不对,心想肯定还有供电的好信号和这个信号相连,因为以前修B460都是比较简单的通病故障,就以为3、5V出来了,其它几路供电也没问题,后面一量内存电压没出来,一量内存供电芯片U5的1P有3.3V正常的,然后一看,这芯片好像是同事换过的,又量了一圈工作条件,都正常的,用示波器量上下管G极没有波形,果断换芯片了,结果还是一样不出,但是这次一量上下管G极有波形了,心想应该是上下管或者电容坏了,手上330电容比较多, 就先换了电容,电压出来了,电流跑0.23,一量U5第3P还是为0.6V,心想还有电压没出,看了一下时序图,量了一下1.05V没出,量了一下工作条件,量了14P的时候只有0.8V,心想不对吖,这个BOOT脚正常应该为5V左右,我用万用表量了一下C439的两脚,值为14欧,这里又自以为是了,直接换个电容,换了还是不行,一量还是14欧,由于U42和U5芯片是一样的,我又量了一下C526,值为549欧,又用示波器量上下管G极没波形,这才换的芯片。

因为之前太果断了,这次怕被坑,换了1.05V出来了,电流还是跑0.23,一量CPU开启信号已经出来,马上装U和内存,电流还是跑0.30,心想:哇靠,这是跟哥杠上了吖!告诉大家吧,这里才到一半呢,后面还有一半艰辛的坑路等着我呢。当1.05V出来以后,CPU的开启信号已经出来了,就是因为出来了,这里又被坑了一圈,那滋味不好受,把CPU芯片的工作条件量了一圈,没发现异常,为什么没有没有发现异常呢,那是因为我把1.05V电压误以为是和VCCP是一个电压了,就没有去量CPU的VID信号,心想1.05V都出来了,VID信号就应该有的,后面被了一大圈之后才发现没有VID,一量没有VCCP电压,这次一量U65的14P,也是只有0.8V,一量电容C655两端值为14欧,又打了一下上下管的G极,没有波形,换芯片,VCCP出来了,装U和内存,通电电流闪一下0.56就掉了,不装U就停在0.23,反复试了几次都是这样,下班了,回家,一路上都在想,应该是保护了,才会闪一下掉电。

          第四天,因为闪一下0.56就掉电这个故障之前修B460的时候也遇到过,一直都没有修好,心想难道这次又要止步于此么,不甘心吖,心想CPU芯片换过的,暂时先排除是芯片的问题,先修修周围电路吧,怀疑电容,把CPU和集显的电容都换了,不行,心想铁壳是换过的,刚想排除铁壳的时候,心想不对,因为铁壳是之前修机器时留下来的,旧的,心想反正都换了这么多芯片,也不在乎这四个铁壳的钱了(原因最后总结的时候会告诉大家的),直接去买了两组新的铁壳,换上去电流到0.60不动,一量没CPU供电,换CPU(因为怕因为最开始的大短烧CPU),不行,瞬间有一种想砸板的冲动,没思路了,吃午饭了,吃了饭去抽了只烟,回来心想都修到这种地步了肯定不能放弃,宁愿把板修好再砸板至少证明我能修好这板,这是气话,这里突然想起之前看了一篇迅维老大饼哥的H55和H65的时序,想起集显电压有时会在CPU电压之前出来,没想那么多了,也没什么好想的。

因为已经心力绞碎了,一量,没集显电压,然后又去看了一下时序图,果然是在CPU之前出来,又看到希望了,一量U61工作条件都有,打了一下上下管的G极,有波形,果然换一组上下管,之前换过电容的,集电电压出来了,电流还是跑0.60,那种心情大家应该知道吧,没办法,不能放弃,这次肯定是到CPU供电了,所有供电都出来了,又量了一圈CPU芯片的工作条件,可能是之前大意了,这次量发现芯片16P只有1.4V,不对吖,这里应该是5V,一量电阻R539第2P有5V,1P只有1.4V,一量阻值,变大了,到这个时候,电阻我都不想找了,因为是1.2欧的,直接拆掉,加一锡连起来,一通电,电流跑到0.80,CPU电压出来了,心里那个高兴吖,不过怎么感觉不对,电流始终是跳一下0.54再跳一下0.80,不过内存,换U换内存都不行,我FUCK!FUCK!FUCK!没办法,难道不修了么,量了一下,内存槽第30P内存怎复位1.5V正常,之前看过的帖子说是如果不过显卡也会有这种现象,然后就用风枪加热了一下显卡,不行,又想到CPU座空焊也有可能影响不过内存,加热了一下也不行,有点无语了,又刷了一次BIOS,不行,然后又上假负载量内存工作条件,本来想量一下时钟正不正常的,结果看到假负载上面的基准电压那个测试点的四个大字了,一量1.5V,不正常,正常应该是0.75V,一量U55的第3P也是1.5V,其它工作条件正常,到这里感觉看到希望了,直接换芯片,通电,电流跳了几次跳到1.5几,心怀激动的接上屏。

通电测试,终于看到LOGO了,此时那心情激动的,那份感动!

评论一下 分享本文 联系我们
网际圈
  • 评论一下
    挤眼 亲亲 咆哮 开心 想想 可怜 糗大了 委屈 哈哈 小声点 右哼哼 左哼哼 疑问 坏笑 赚钱啦 悲伤 耍酷 勾引 厉害 握手 耶 嘻嘻 害羞 鼓掌 馋嘴 抓狂 抱抱 围观 威武 给力
    提交评论

    清空信息
    关闭评论